Back to overview
Downtime
Channex services down
Apr 30, 2026 at 4:57pm UTC
Affected services
API
Resolved
Apr 30, 2026 at 5:28pm UTC
We're fixed errors. Sorry for any inconvinience.
Affected services
Created
Apr 30, 2026 at 4:57pm UTC
Channex servers are currently down for bookings and ARI updates. We are working on the issue to try and recover.
Affected services