Back to overview
Downtime

Channex Services Down

Apr 29, 2026 at 2:00pm UTC
Affected services
API

Resolved
Apr 29, 2026 at 6:34pm UTC

All PMS should make a full sync of availability for all rooms and proeprties. Please send 1 property at a time till all are done

Updated
Apr 29, 2026 at 6:29pm UTC

Horrible outage and huge apology to everyone affected. Our RabbitMQ servers went down with OOM. nothing could make them work again. We managed to get it working not by just a small server upgrade but giant huge one. Apologies it too so long to get back online and we hope to not see or suffer this again. This has been our longest outage over our 6 years!

We are working on getting missing bookings from Booking, Expedia, Agoda, Ctrip and Airbnb. All other OTA most likely the bookings went to email and no way to pull them.

Updated
Apr 29, 2026 at 5:18pm UTC

We have hadall our queues go down and will not restart, looks like a longer problem to fix than hoped for. Please notify all clients to manage their calendar manually in the OTA for sold out dates. We will try hard to get this working but it seems it will be hours longer. We apologise for the pain caused to you and your clients.

Created
Apr 29, 2026 at 2:00pm UTC

Channex servers are currently down for bookings and ARI updates. We are working on the issue to try and recover