Back to overview
Degraded

Bcom sync issues

Feb 27 at 03:00pm CET
Affected services
Booking.com

Resolved
Feb 27 at 04:22pm CET

Bcom resolved their issues

Created
Feb 27 at 03:00pm CET

Bcom's Cloudflare respond with 504 error.