Back to overview
Degraded

Booking.com Reservation Delays

Aug 28 at 04:46am CEST
Affected services
Booking.com

Resolved
Aug 29 at 01:31am CEST

Booking.com have fixed the issue and all should be back to normal

Created
Aug 28 at 04:46am CEST

Booking.com have outages affecting bookings causing over 1 hour delays.