Back to overview
Degraded

VRBO Downtime

May 01 at 10:06pm CEST
Affected services
API

Resolved
May 03 at 10:00am CEST

VRBO is working again. we will update all availability and get bookings missed.

Created
May 01 at 10:06pm CEST

VRBO connection is down. We are working on this but you need manage this channel manually or with ical from the PMS.