Back to overview
Downtime
Booking.com is down
Feb 20, 2024 at 5:05pm UTC
Affected services
Booking.com
Resolved
Feb 20, 2024 at 9:31pm UTC
Booking have restored the service and we are sending all delayed syncs
Affected services
Created
Feb 20, 2024 at 5:05pm UTC
Booking.com is down for all availability and price updates. We will monitor the situation and sync all updates once they come online again
Affected services